> Tous les forums > Forum Linux
 [Résolu] Nvidia, problème videos
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
pimous
  Posté le 09/01/2014 @ 20:48 
Aller en bas de la page 
Petit astucien

Bonsoir

Pour régler de problèmes de lignes horizontales qui scintillent qui montent et qui descendent sur les vidéos, j'ai installé les drivers de ma carte graphique Nvidia, mais il y a aucun changement,
y a t-il quelque chose à paramétrer ou autre pour régler le problème ?

Merci par avance.



Modifié par pimous le 27/01/2014 17:12
Publicité
Logicien
 Posté le 10/01/2014 à 00:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut/Bonsoir,

à priori, on pourrait penser que les pilotes ne sont pas à l'origine du problème, à moins que les deux le soient. Pour précision, à l'origine, utilisais-tu le pilote libre Nouveau, à moins que ce soit le pilote Nv, et tu es passé au pilote propriétaire Nvidia?

Comment sais-tu qu'Xorg utilise maintenant le pilote Nvidia et non plus celui d'avant?

As-tu essayé de modifier le rafraîchissement et la résolution de l'écran pour voir si ça réglait le problème?

Quand tu regardes la sortie de la commande

glxinfo | less

est-ce que tu vois

direct rendering: Yes

Est-ce que ton problème se produit seulement quand tu regardes des vidéos?

Quelle distribution utilises-tu?



Modifié par Logicien le 10/01/2014 00:43
pimous
 Posté le 11/01/2014 à 15:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

C'est un problème de (Tearing)

Ça se passe aussi bien avec les pilotes libres qu'avec les propriétaires Nvidia,

j'ai du réinstaller opensuse avec kde, après un plantage, je me retrouve de nouveau avec les pilotes libres, je préfèrerais régler le problème avec les pilotes libres.

Résultat de la commande : glxinfo | less

glxinfo: command not found
lines 1-1/1 (END)

Oui, le problème est uniquement quand je regarde des vidéos, toutes videos en ligne et sur tout lecteurs video, vlc, smplayer,.............



Modifié par pimous le 12/01/2014 15:25
Logicien
 Posté le 12/01/2014 à 21:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour avoir la commande glxinfo, il faudrait que tu installes le paquet mesa-progs . C'est important de savoir si tu as le direct rendering: Yes.

Il est aussi important de savoir quel pilote libre tu utilises, nv ou nouveau. Si tu as des problèmes avec un pilote libre essai l'autre. Chacun se ces pilotes a des options qui peuvent aider à réduire l'effet de déchirement. Voir les pages de manuels man nv et man nouveau .

Pour éviter cet effet, il y a quelques possibilités que j'ai explorées. Tu peux te créer un fichier $HOME/.drirc avec ces lignes

<driconf>
<device screen="0">
<application name="all">
<option name="vblank_mode" value="2" />
</application>
</device>
</driconf>


Tu peux aussi écrire dans ton .bashrc

export vblank_mode=2

et redémarrer ta session. Ces variables font en sorte que les applications se synchronisent avec le balayage vertical de l'écran, ce qui réduit l'effet de déchirement. Cela fait aussi que les applications ne vont pas plus vite que la fréquence de rafraîchissement verticale utilisée par l'écran.



Modifié par Logicien le 12/01/2014 21:28
pimous
 Posté le 12/01/2014 à 23:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

sous susse la commande était un peux différente,Voici le résultat:

rozo # glxinfo | grep "direct rendering"
direct rendering: Yes

Pour le résultat de la commande man nv, je comprends pas l'anglais, et c'est surement des termes techniques.

-----------------------------------------------------

Pour créer un fichier $HOME/.drirc, je comprends pas tres bien,

je crée un fichier texte, je le nome $HOME/.drirc.txt, et dedans j’écris:

<driconf>
<device screen="0">
<application name="all">
<option name="vblank_mode" value="2" />
</application>
</device>
</driconf>

Ou je mets ce fichiers apres ?


---------------------------------

En suite, je comprends pas nom plus:

(Tu peux aussi écrire dans ton .bashrc : export vblank_mode=2)

c'est quoi le (bashrc), ca se trouve ou ?



Modifié par pimous le 12/01/2014 23:51
Logicien
 Posté le 12/01/2014 à 23:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

C'est $HOME/.drirc , donc sans l'extension .txt . $HOME est une variable qui contient le chemin complet vers la racine du répertoire personnel de l'utilisateur connecté à son bureau et avec lequel tu travailles. Donc la variable $HOME contient /home/nom-utilisateur .

Tu écris à l'aide de l'éditeur de texte de ton choix dans le fichier $HOME/.drirc ce que je t'ai donné et tu sauvegardes. Tu n'as pas besoin des droits du super-utilisateur root pour faire les manipulations dans les fichiers $HOME/.drirc et $HOME/.bashrc. Les droits de l'utilisateur connecté suffisent puique les manipulations se passent dans son propre répertoire personnel.

Oui les pages de manuels nv et nouveau sont techniques. C'est pourquoi il faut savoir quel pilote Xorg utilise pour faire les bonnes nanipulations si nécessaire.

Si tu peux mettre le contenu du fichier /var/log/Xorg.0.log sur un site pastebin comme Pastebin - Type, paste, share. et afficher le lien pour voir le fichier je pourrai mieux t'aider.



Modifié par Logicien le 13/01/2014 00:07
pimous
 Posté le 13/01/2014 à 00:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

j'ai fait une cherche avec l'explorateur de Dolphin de $HOME/.drirc et $HOME/.bashrc, Dolphin ne trouve pas ces fichiers

j'ai tapé : grep -i -e nv -e nouveau /var/log/Xorg.0.log | less, avec la flèche, j'arrive jusqu’à la fin, c'est assez long, je voudrais te montrer le résultat, mais j'ai pas trouvé le moyen de tout sauvegarder

je fait en haut a gauche de la fenêtre du terminal > fichier>enregistrer la sortie sous, et ça enregistre qu'une partie, la partie visible à du terminal.

J'ai bien essayé de cliquer sur "Edition" tout en haut a gauche de la fenêtre du terminal, mais "Tout sélectionner" est grisé



Modifié par pimous le 13/01/2014 00:33
Logicien
 Posté le 13/01/2014 à 03:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

J'ai modifié mon message précédent. Si les fichiers .drirc et .bashrc n'existent pas, tu peux les créer sans problème.

Si tu peux mettre le contenu du fichier /var/log/Xorg.0.log sur un site pastebin comme Pastebin - Type, paste, share. et afficher le lien pour voir le fichier je pourrai mieux t'aider. Tu peux te servir d'un navigateur Web ou d'un éditeur de fichiers textes pour afficher le contenu du fichier, tout sélectionner, copier et coller comme texte du lien que je te donne.

Un problème serait que le navigateur ne puisse pas afficher le fichier par manque de permissions.



Modifié par Logicien le 13/01/2014 03:28
pimous
 Posté le 13/01/2014 à 15:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Une fois le fichier

Pour créer les fichiers $HOME/.drirc et $HOME/.bashrc, je crée deux fichier text, que je renomme en
$HOME/.drirc et $HOME/.bashrc ?, ou il y a un autre façon bien spéciale de créer ces deux fichiers ?

une fois crée, je les mets ou ?

Excuse moi pour tout e ces questions, mais j'ai déjà réinstallé trois fois Opensuse, je un peu peur que ça plante après une mauvaise manipulation.

Voici le résultat de la commande grep -i -e nv -e nouveau /var/log/Xorg.0.log | less

Voici: pastebin.ca/2535538



Modifié par pimous le 13/01/2014 15:09
Publicité
Logicien
 Posté le 13/01/2014 à 18:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Quand tu ouvres un éditeur de texte, tu peux entrer du texte et le fichier est sans nom à ce moment. C'est quand tu l'enregistres pour la première fois que tu dois lui donner un nom. Tu dois enregistrer les fichiers .drirc et .bashrc à la racine de ton répertoire personnel.

En supposant que le nom de l'utilisateur connecté est pimous, alors, les fichiers .drirc et .bashrc doivent être enregistrés dans les chemins complets /home/pimous/.drirc et /home/pimous/.bashrc. Remplace pimous par le nom réel de l'utilisateur qui a ouvert la session avec lequel tu travailles.

Tu utilises le pilote nouveau. Avant d'aller plus loin, assure-toi que les fichiers .drirc et .bashrc sont bien enregistrés sous les bons noms et aux bons endroits. Redémarre ta session et test si tu as encore du 'tearing' quand tu visionnes des vidéos.



Modifié par Logicien le 13/01/2014 18:12
pimous
 Posté le 13/01/2014 à 21:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Lors de la création des fichier, j'ai fait

>créer nouveau fichier texte, j'ai tapé les ligne de commande, puis> enregistrer sous, et la je renomme en $HOME/.drirc et $HOME/.bashrc, puis j'ai eu message:

http://www.casimages.com/img.php?i=140113095430391757.jpg

----------------------------------------

alors, j'ai fait autrement, j'ai crée les fichiers texte avec les ligne de commande dedans, enregistrer toujour en text, puis je les ai renommés en $HOME/.drirc et $HOME/.bashr, et la c'est passé:

http://www.casimages.com/img.php?i=140113095128919905.jpg

mais après redémarrage, j'ai toujours le problème à la lecture de vidéos,

------------------------------------------

en ouvrant, $HOME⁄.bashrc, je me suis aperçu que les lignes de commande se sont mis en gras et en couleur:

http://www.casimages.com/img.php?i=140113095632144636.jpg

en ouvrant, $HOME⁄.drirc, celui ci est resté en noir,

http://www.casimages.com/img.php?i=140113095727442861.jpg

le problème viendrait-il de la, en noir, veut dire que ça na pas été pris en compte ?



Modifié par pimous le 13/01/2014 21:54
Logicien
 Posté le 15/01/2014 à 05:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La couleur du texte ne change pas son contenu. Redémarre ton ordinateur pour savoir si ça aide.

As-tu regardé les paramètres du lecteur vidéo que tu utilises? Lequel utilises-tu?

On peut essayer de passer des paramètres aux pilotes Nouveau. Il faudrait que tu affiches la sortie de la commande

dmesg | grep -i -e drm -e kms -e nouveau

On peut même changer le pilote graphique nouveau pour le pilote graphique nv au besoin. Il n'y a aucune garantie que ça va régler le problème. Ça peut venir d'une mauvaise configuration à plusieurs niveaux

- le lecteur vidéo

- la configuration du bureau

- du serveur graphique et le pilote

- la configuration du noyau Linux

Il y a sûrement une solution, mais si tu n'arrives pas à résoudre ton problème, tu peux envisager de changer de distribution GNU/Linux pour une autre qu'OpenSUSE. Peut-être que ce problème n'existera pas.



Modifié par Logicien le 15/01/2014 05:36
pimous
 Posté le 15/01/2014 à 12:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bien les paramètres vidéos, c'est pas un en particulier, c'est tout les lecteurs, vlc, mlayer, kaffeine, ............., et sur tout site de streaming en ligne, youtube, dailymotion, ............

Voici les résultat de la commande, dmesg | grep -i -e drm -e kms -e nouveau :

:~> dmesg | grep -i -e drm -e kms -e nouveau
[ 1.012932] [drm] Initialized drm 1.1.0 20060810
[ 1.015717] fb: conflicting fb hw usage nouveaufb vs EFI VGA - removing generic driver
[ 1.016081] nouveau [ DEVICE][0000:01:00.0] BOOT0 : 0x0d9000a1
[ 1.016083] nouveau [ DEVICE][0000:01:00.0] Chipset: GF119 (NVD9)
[ 1.016085] nouveau [ DEVICE][0000:01:00.0] Family : NVD0
[ 1.017666] nouveau [ VBIOS][0000:01:00.0] checking PRAMIN for image...
[ 1.096476] nouveau [ VBIOS][0000:01:00.0] ... appears to be valid
[ 1.096478] nouveau [ VBIOS][0000:01:00.0] using image from PRAMIN
[ 1.096554] nouveau [ VBIOS][0000:01:00.0] BIT signature found
[ 1.096556] nouveau [ VBIOS][0000:01:00.0] version 75.19.36.00.08
[ 1.096752] nouveau [ PFB][0000:01:00.0] RAM type: DDR3
[ 1.096753] nouveau [ PFB][0000:01:00.0] RAM size: 1024 MiB
[ 1.096754] nouveau [ PFB][0000:01:00.0] ZCOMP: 0 tags
[ 1.121226] nouveau [ PTHERM][0000:01:00.0] FAN control: PWM
[ 1.121230] nouveau [ PTHERM][0000:01:00.0] fan management: disabled
[ 1.121234] nouveau [ PTHERM][0000:01:00.0] internal sensor: yes
[ 1.124455] nouveau [ DRM] VRAM: 1024 MiB
[ 1.124456] nouveau [ DRM] GART: 1048576 MiB
[ 1.124460] nouveau [ DRM] TMDS table version 2.0
[ 1.124461] nouveau [ DRM] DCB version 4.0
[ 1.124463] nouveau [ DRM] DCB outp 00: 02000300 00000000
[ 1.124464] nouveau [ DRM] DCB outp 01: 01000302 00020030
[ 1.124466] nouveau [ DRM] DCB outp 02: 02011362 00020010
[ 1.124467] nouveau [ DRM] DCB conn 00: 00001030
[ 1.124469] nouveau [ DRM] DCB conn 01: 00002161
[ 1.125171] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 1.125172] [drm] No driver support for vblank timestamp query.
[ 1.125439] nouveau [ DRM] 2 available performance level(s)
[ 1.125441] nouveau [ DRM] 1: core 270MHz shader 540MHz memory 405MHz voltage 900mV
[ 1.125443] nouveau [ DRM] 3: core 810MHz shader 1620MHz memory 897MHz voltage 1040mV
[ 1.125445] nouveau [ DRM] c: core 270MHz shader 540MHz memory 405MHz voltage 900mV fanspeed 28%
[ 1.130868] nouveau [ DRM] MM: using COPY0 for buffer copies
[ 1.199219] nouveau [ DRM] allocated 1920x1080 fb: 0x60000, bo ffff8801358b6400
[ 1.199342] fbcon: nouveaufb (fb0) is primary device
[ 1.255429] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
[ 1.255430] nouveau 0000:01:00.0: registered panic notifier
[ 1.255432] [drm] Initialized nouveau 1.1.1 20120801 for 0000:01:00.0 on minor 0



Modifié par pimous le 15/01/2014 12:28
Logicien
 Posté le 15/01/2014 à 13:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Côté noyau Linux, le pilote Nouveau semble bien fonctionner. C'est ce que dit la sortie de la commande précédente. Je ne vois pas de meilleurs paramètres à lui passer. Il y a le pilote Nouveau pour l'interface graphique Xorg aussi. Tu m'as déjà fourni le fichier /var/log/Xorg.0.log. Tout semble bien fonctionner de ce côté aussi. Je ne vois pas de meilleurs paramètres à lui passer à lui aussi.

Il reste à essayer le pilote Nv. Ragarde avec Yast si le paquet xf86-video-nv ou un nom semblable est installé. Sinon, installe-le. Pour forcer Xorg à l'utiliser, il faut créer un fichier, mais cette fois-ci, il faut les droits administratifs du super-utilisateur root. Donc, il faut que tu ouvres une session root, est-ce que tu connais le mot-de-passe root? C'est nécessaire.

Pour ouvrir une session root en mode graphique, tu ouvres un terminal avec l'utilisateur non-root et tu exécutes la commande

xhost +

Puis,

su -

On te demande ton mot-de-passe. Après, tu es connecté en tant que root. Tu devrais voir un # plutôt qu'un $ à la fin de l'invite de commandes. Il faut créer un répertoire avec la commande

mkdir /etc/X11/xorg.conf.d

Si on te dit que le répertoire existe déjà et qu'il ne peut donc pas être créé, c'est correct. Maintenant, tu ouvres l'éditeur de ton choix par exemple Gedit avec la commande

gedit

Tu copies les lignes suivantes

Section "Device"
BoardName "Nvidia"
Driver "nv"
Identifier "Nv"
VendorName "Nvidia"
EndSection

Tu sauvegardes le contenu dans le répertoire /etc/X11/xorg.conf.d/ avec le nom 99-video-nv.conf . Donc, le chemin complet du fichier est /etc/X11/xorg.conf.d/99-video-nv.conf . Pour sortir de la session root, Tu tapes Ctrl+d . Puis, tu redémarres ton ordinateur.

Tu fais des tests vidéos et tu m'en donnes des nouvelles. J'espère que tu y arriveras. Je ne vois pas autre chose de mieux et de plus facile. Ça ne devrait pas causer de problème, sinon que d'avoir à supprimer tous les fichiers que je t'ai fais créer si rien ne s'améliore.

Je part pour la journée. Je ne serai pas de retour avant la soirée, soit la nuit en Europe de l'ouest.



Modifié par Logicien le 15/01/2014 13:57
pimous
 Posté le 16/01/2014 à 01:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

il y a un problème quand j' essaye de sauvegarder dans etc/X11/xorg.conf.d,

j'ai ce message : http://www.casimages.com/img.php?i=140116020346189762.jpg

et avec le clique droit dans le répertoire, je n'ai pas l'option pour créer un fichier

---------------------------------------------

Les deux fichiers $HOME/.drirc et $HOME/.bashrc, j'en ai encore besoin ?, ça fonctionne avec 99-video-nv.conf ?

je dis ça par ce que je les ai supprimés je voudrais savoir si je dois les recréer



Modifié par pimous le 16/01/2014 08:39
reivillo
 Posté le 16/01/2014 à 15:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour pimous.

il y a un problème quand j' essaye de sauvegarder dans etc/X11/xorg.conf.d,

Il faut être root, pour modifier xorg.conf.d

Reivillo.



Modifié par reivillo le 16/01/2014 17:27
pimous
 Posté le 16/01/2014 à 17:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

j'ai pas de fichier xorg.conf.d,

xorg.conf.d est un répertoire, je dois y mettre le fichier crée (99-video-nv.conf) avec les ligne,

comment déplacer 99-video-nv.conf dans xorg.conf.d en Root ?



Modifié par pimous le 16/01/2014 17:19
Publicité
reivillo
 Posté le 16/01/2014 à 17:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Excuse pour Fichier.....j'ai corrigé.

Ouvre la Console et Tape: gksu (suivi du nom de ton gestionnaire de Fichier)[exemple; thunar, nautilus, caja ou autres]

puis, rentre ton mot de passe.



Modifié par reivillo le 16/01/2014 17:40
pimous
 Posté le 16/01/2014 à 18:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci, juste une petite question avant de faire cette manipe, tout Dolphin ouvert, niveau sécurité, il y a pas de risque ?



Modifié par pimous le 16/01/2014 18:53
Logicien
 Posté le 16/01/2014 à 19:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

pimous,

je ne comprend pas que l'image parle du chemin complet /usr/share/X11/xorg.conf.d/ pour le fichier 99-video-nv.conf, soit /usr/share/X11/xorg.conf.d/99-video-nv.conf . Le chemin complet dont je parle est /etc/X11/xorg.conf.d/99-video-nv.conf . Donc, si avec les droits root tu a écris un fichier /usr/share/X11/xorg.conf.d/99-video-nv.conf, supprime-le. Assure-toi que le fichier /etc/X11/xorg.conf.d/99-video-nv.conf est bien créé, soit le fichier 99-video-nv.conf dans le répertoire /etc/X11/xorg.conf.d/ .

Pour ce qui est des fichiers que je t'ai fait créer jusqu'à maintenant, soit $HOME/.drirc , $HOME/.bashrc et /etc/X11/xorg.conf.d/99-video-nv.conf , tu peux ne garder que ceux qui résolvent ton problème et supprimer les autres. Si .drirc et .bashrc n'ont pas résolu ton problème et que 99-video-nv.conf lui l'a résolu, alors tu devrais pouvoir supprimer les fichiers .drirc et .bashrc sans que le problème revienne. Sinon, tu devras les recréer.



Modifié par Logicien le 16/01/2014 19:12
reivillo
 Posté le 16/01/2014 à 21:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

merci, juste une petite question avant de faire cette manipe, tout Dolphin ouvert, niveau sécurité, il y a pas de risque ?

Les risques ? c'est qu’après tes manips, tu laisses ton gestionnaire de fichier Ouvert.

Donc, quand tu fermes ton gestionnaire de fichier, puis la Console: Tu n'es plus root.

Voir avec sudo, en lieu et place de gksu;

Si tu ferme la Console avant le gestionnaire de fichier,

ton gestionnaire de fichier, sera fermer d' Autorité par root.

Sécurité Linux oblige.

Je pense t'avoir rassuré pour l'avenir.

Reivillo.



Modifié par reivillo le 19/01/2014 17:24
pimous
 Posté le 16/01/2014 à 23:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci reivillo,

Logicien,

entre temps, je travaillais sur autre chose, j'ai fait planter la distribution, je l'ai réinstallé depuis, et fait les mises à jour, je pense pas que ça change quelque chose à la manipe que tu m'a demander de faire,

je viens de la faire et au redémarrage, j'ai un écran noir avec ce message:

Welcom to opensuse 13.1"Bottle-Kernel 3.11.6-4-desktop (tty1).

linux-z6jr login:_

dit, moi si il y a quelque chose de spéciale à faire ?

sinon, je réinstalle et j'essaye cette fois 99-video-nv.conf avec $HOME/.drirc et $HOME/.bashrc



Modifié par pimous le 16/01/2014 23:56
Logicien
 Posté le 17/01/2014 à 04:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Les fichiers .drirc et .bashrc avec la variable vblank_mode=2 créent un environnement d'affichage graphique où la carte graphique envoie les images à l'écran à la même fréquence verticale que ce que l'écran supporte, plutôt que d'envoyer les images à la vitesse maximale que la carte graphique supporte comme c'est la cas quand vblank_mode=0 . Tu peux essayer les deux valeurs soient vblank_mode=2 et vblank_mode=0 dans les fichiers .drirc et .bashrc et faire des tests pour voir si une ou les deux valeurs aident.

Quant au fichier 99-video-nv.conf, il change le pilote vidéo Nouveau d'Xorg pour ta carte graphique pour le pilote Nv. Le pilote vidéo du noyau Linux reste Nouveau. Le pilote Nouveau de Linux et le pilote Nv d'Xorg devraient pouvoir cohabiter ensembles. Toutefois, le changement est plus important que vblank_mode. S'il y a un problème l'affichage peut devenir disfonctionnel, voir faire planter le système. C'est pourquoi je te recommande d'utiliser le pilote Nv seulement si vblank_mode=2 et vblank_mode=0 ne donnent rien.

Note que tu dois installer le pilote Nv s'il ne l'est pas pour pouvoir l'utiliser. Il se nomme xf86-video-nv ou quelque chose de semblable.



Modifié par Logicien le 17/01/2014 04:45
pimous
 Posté le 18/01/2014 à 23:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

j'ai essayé, $HOME/.drirc et $HOME/.bashrc en 0, pas de changement. En réinstallant donc sans les fichiers vidéo-$HOME, j'ai essayé 99-vidéo-nv.conf, avec xf86-vidéo-Nv, qui était déjà installé, écran noir avec le même message au redémarrage.

Logicien
 Posté le 19/01/2014 à 00:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Il semble que le pilote Nv pose problème plus que le pilote Nouveau. Si tu ne veux pas tout réinstaller, tu dois supprimer le fichier /etc/X11/xorg.conf.d/99-video-nv.conf . Cela fera en sorte que le pilote Nouveau sera celui qui sera utilisé par Xorg. Donc, retour à la case départ.

Yast doit bien avoir dans ses paquets les pilotes propriétaires Nvidia que tu peux installer. Peut-être est-ce la dernière chance de résoudre ton problème en changeant de pilote vidéo.

Tu peux encore essayer d'utiliser le pilote framebuffer. Les performances sont réduites. Après avoir supprimer 99-video-nv.conf, tu crées 99-video-fbdev.conf. Tu n'as qu'à remplacer nv par fbdev dans les lignes que contenaient le fichier /etc/X11/Xorg.conf.d/99-video-nv.conf.

Pour ce qui est des lecteurs vidéos, assure-toi que le pilote utilisé dans les Préférences est xv . S'il ne fonctionne pas sans 'tearing', essai en un autre, x11 par exemple, ainsi de suite.



Modifié par Logicien le 19/01/2014 00:44
pimous
 Posté le 19/01/2014 à 19:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ma carte est une nvidia geforce Gt-520, les pilotes propriétaire: nvidia-gfxG03-kmp-desktop, j'ai également du Tearing avec,

--------------------------------------


après avoir installé le pilote, je tape dans le terminal en root:

nvidia-xconfig

j'obtiens ce message:

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

-------------------------------------

après, je tape nvidia-settings, dans nvidia settings je clique sur Save x configuration file, j'obtiens ce message:

linux-hz3j:/home/riton # nvidia-settings
Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found

--------------------------------------

pourtant quand les pliotes nvidia sont installés, xorg sevrer est présent:

http://www.casimages.com/img.php?i=140115083557249428.jpg

Je sais pas si c'est lié au problème, je vois deux autres xorg x11 server, peut être faut-il que j'en installe un autre ?

Avant, cette opération réglait le problème, j'avais qu'a faire Save x configuration file, puis redémarrer l'ordi, pour que le tearing disparaisse

----------------------------------------------------------

sinon pour l'autre solution

assure-toi que le pilote utilisé dans les Préférences est xv et essai en un autre, x11

Comment fait-on ces deux chose ?:



Modifié par pimous le 19/01/2014 19:08
Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Problème de partitionnement (clôturé non résolu)
Probleme installation Pilote Nvidia fx5200
probleme de pilote = Resolu =
-Résolu- problème graver un dvd-rw de donnés
[NON RESOLU] Problème acroread et KGhostview
etrange probleme au demarrage [resolu]
problème de droits [résolu]
Problème de langue Mandrakelinux 10.2 [résolu]
Problème installation carte son (Résolu)
Problème nom de point de montage (Résolu)
Plus de sujets relatifs à [Résolu] Nvidia, problème videos
 > Tous les forums > Forum Linux